Opened 18 months ago

Closed 18 months ago

Last modified 18 months ago

#1488802 closed Bugs (fixed)

Compose message page reloads

Reported by: dulemis Owned by:
Priority: 3 Milestone: 0.8.4
Component: User Interface Version: 0.8.3
Severity: major Keywords:
Cc: SKaero@…

Description

When composing a new message and writing the receiver adress after a couple of characters the page seem to reload in some way, because the To-field gets emptied. Have tried with different addresses, and it's the same. The strange thing is that it happens sporadic, not all the time.
Probably something with the autocomplete feature?

Attachments (1)

rc_autocomplete.png (55.8 KB) - added by SKaero 18 months ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 18 months ago by alec

  • Component changed from Core functionality to User Interface
  • Milestone set to 0.9-beta

All requests in compose screen should be in background (ajax). Could you use some debug tool (like Firebug in Firefox) to check what request it is? What params/headers it sends. Disable all plugins.

comment:2 Changed 18 months ago by dulemis

It worked just fine in 0.8.1 with the same plugins.
Following plugins are active:

'nutsmail_theme_selector','dblog','eitss_login','demologin','threecol','movespam','markasjunk2','new_user_dialog','lang_sel','quota', 'vacation','password','listcommands','dkim_verify','dkim_sign','planner','persistent_login','contextmenu','emoticons','automatic_addressbook','keyboard_shortcuts','archive','copymessage','folderbuttons','newmail_notifier','message_label','dragndrop_attachments','compose_newwindow','importmessages'

Following is the request from FireBird?. However, i cannot see the post when the page reloads cause it also cleans the actual info in Firebird.

HTTP POST: ./?_task=mail&_action=autocomplete

app.js...2597665 (rad 22)
POST https://webmail.speedcom.se/ny/?_task=mail&_action=autocomplete

200 OK

296ms

jquery...2597666 (rad 4)
ParamsHeadersPostResponseJSONKakor
Response Headers
Cache-Control private, no-cache, must-revalidate, post-check=0, pre-check=0
Connection close
Content-Type text/plain; charset=UTF-8
Date Mon, 12 Nov 2012 09:33:04 GMT
Expires Mon, 12 Nov 2012 09:33:04 GMT
Last-Modified Mon, 12 Nov 2012 09:33:04 GMT
Pragma no-cache
Server Apache
Transfer-Encoding chunked
X-Powered-By PHP/5.3.8
x-dns-prefetch-control off
Request Headers
Accept application/json, text/javascript, */*; q=0.01
Accept-Encoding gzip, deflate
Accept-Language sv-se
Connection keep-alive
Content-Length 67
Content-Type application/x-www-form-urlencoded; charset=UTF-8
Cookie mailviewsplitter=310; mailviewsplitterv=226; language=sv; composesplitterv=248; mailviewsplittertc=650; addressviewsplitterd=226; addressviewsplitter=286; utma=137752178.159358398.1348220077.1349942695.1350461298.9; utmz=137752178.1349876452.7.2.utmcsr=us2.campaign-archive2.com|utmccn=(referral)|utmcmd=referral|utmcct=/; epl_siteuser=5917b302bf61a549bd48e9168678d86d46e88c46; utmc=137752178; roundcube_sessid=faaniv4ngnqbant1rqrajg4d42; epl_user=huvudse; epl_db=1; roundcube_sessauth=S8df5a3f341a607c0b0380950ee8f40b894f53ff7
Host webmail.speedcom.se
Referer https://webmail.speedcom.se/ny/?_task=mail&_id=89433596150a0c19778ddb&_action=compose
User-Agent Mozilla/5.0 (Windows NT 5.1; rv:16.0) Gecko/20100101 Firefox/16.0
X-Requested-With XMLHttpRequest
X-Roundcube-Request 51fb382b128b1ac979040b826b00fef7

this.enable_command("add","import",false);
this.ksearch_query_results(Dusan Ilic <dusan@joksi.net>?,"du","1352712780713");

comment:3 Changed 18 months ago by SKaero

  • Cc SKaero@… added

I think I may have run into the same problem also although the problem I'm having is slightly different. When writing in any of the autocomplete boxes RoundCube will sometimes forward to <RC base url>/null it seems to happen when typing fast (or if you have a slow net connection) and a second autocomplete request occurs before the first is complete. It seems to happen more while using the classic skin that it does when I'm using larry but I was able to get it to happen in larry but typing in one field and then tabbing to the next and typing there. The problem is occurring in a fresh install of RC 0.8.3 with no plugins clear cache and cookie on PHP 5.3.18. I've attached a sreenshot of the Chrome js console with the requests.

Changed 18 months ago by SKaero

comment:4 Changed 18 months ago by alec

  • Priority changed from 5 to 3

I'm unable to reproduce this in git-master, but in release-0.8 it's simply reproducible now. There's a request just after autocomplete request when you hit TAB key before the autocompletion request finishes.

comment:6 Changed 18 months ago by alec

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in af18b5b06f7045d0d2f76d618ed8831a788931af. It looks that the buggy commit was commited to wrong branch, should go to master where we can test it more. As for the change of the commit, there should be no redirect on aborts.

comment:7 Changed 18 months ago by dulemis

Sorry, I didn't really get if this is fixed or not?
Is there any code I can add or remove in any file to solve this before you release a new version?

comment:8 Changed 18 months ago by dulemis

Should I remove following in /program/js/app.js?

a=a.getResponseHeader("Location"),""!=a&&this.redirect(a)

comment:9 Changed 18 months ago by thomasb

  • Milestone changed from 0.9-beta to 0.8.4
Note: See TracTickets for help on using tickets.