Opened 23 months ago

Closed 23 months ago

Last modified 22 months ago

#1488797 closed Bugs (fixed)

One or two LFs at the end of any composed message

Reported by: myfreexp Owned by:
Priority: 8 Milestone: 0.8.4
Component: Core functionality Version: git-master
Severity: minor Keywords: superfluos line feeds
Cc:

Description

When composing a new message, Roundcube is adding two LFs at the end of each message. When replying, it is adding just one LF.

These LFs are superfluos IMHO, and I need to delete them manually with each composed message. Is it possible to not add these LFs anymore?

Change History (6)

comment:1 follow-up: Changed 23 months ago by alec

  • Milestone changed from later to 0.9-beta

I can confirm this but only for HTML emails. Is this the case?

comment:2 in reply to: ↑ 1 Changed 23 months ago by myfreexp

Replying to alec:

I can confirm this but only for HTML emails. Is this the case?

Nope, I'm talking about text/plain messages only.

comment:3 follow-up: Changed 23 months ago by alec

Hmm.. They are added when you enter compose screen or when you send the message? Is signature added automatically? Are the empty lines added after the sig? Is it possible that the lines are from the signature?

comment:4 in reply to: ↑ 3 Changed 23 months ago by myfreexp

Replying to alec:

Hmm.. They are added when you enter compose screen or when you send the message? Is signature added automatically? Are the empty lines added after the sig? Is it possible that the lines are from the signature?

Ok, I need to be more specific:

1. The LFs are added upon entering the compose screen (otherwise I wouldn't be able to remove them before sending - see original comment).

2. The LFs are NOT part of the signature.

3. My relevant settings under "Composing messages" are:

  • When replying: start new message above original
  • Automatically add signature: always
  • When replying or forwarding place signature: above the quote (RMK: If I'm replying with inline quote style - to the very few people who are still familiar with it - and need to have the sig at the bottom, I'm copying it to the bottom manually - which would be another good feature BTW to be able to configure this user-by-user in the addressbook.)

4. New message (no reply, no quote):

  1. Three LFs are added above the signature (that's OK).
  2. Two LFs are added below the signature (that is what should be avoided).

5. Reply with quote:

  1. Same as 4. a. and b., but that's OK for a top posting (as it creates one blank line between top posting and quote, although in this case I would prefer even two blank lines due to "optical" reasons and a clearer "line" between posting and quote).
  2. One LF is added at the bottom of the message (this may be deliberate, but I wouldn't know why). Or it probably comes from the quoted message, but:
  3. All superfluos LFs of any quoted message should be removed anyway, and - if technically necessary - one LF should be added upon sending (but not upon loading them into the compose screen).

A good start would be to make a distinction between new massages and replies, IMO. At least with "my" settings, other settings may require a different behaviour. I'm happy to offer to test all of them, if you so wish.

comment:5 Changed 23 months ago by alec

  • Resolution set to fixed
  • Status changed from new to closed

Ok, it was related to top_posting. Fixed in 4340d5e63424ffdea2788701c5539c9cdc162eda.

comment:6 Changed 22 months ago by thomasb

  • Milestone changed from 0.9-beta to 0.8.4
Note: See TracTickets for help on using tickets.