Opened 2 years ago

Closed 23 months ago

Last modified 23 months ago

#1488750 closed Bugs (fixed)

Empty message body

Reported by: zamri Owned by:
Priority: 5 Milestone: 0.8.3
Component: MIME parsing Version: 0.8.2
Severity: normal Keywords: empty,body
Cc:

Description

RC doesn't show the message body correctly. Gmail can show it correctly and in the source, I can see there is texts for the body.

I attached the .eml file for testing.

Attachments (2)

Fwd- [Dbmail] current head does not compile on Fedora 17.eml (13.2 KB) - added by zamri 2 years ago.
Email with message body shown empty by RC 0.8.2
jemputan.zip (129.7 KB) - added by zamri 23 months ago.

Download all attachments as: .zip

Change History (12)

Changed 2 years ago by zamri

Email with message body shown empty by RC 0.8.2

comment:1 Changed 2 years ago by zamri

The theme used is Larry.

comment:2 Changed 2 years ago by alec

  • Component changed from Core functionality to MIME parsing
  • Milestone changed from later to 0.9-beta
  • Priority changed from 1 - Highest to 5
  • Severity changed from critical to normal

The message contains multipart/alternative subpart with text/plain and text/html part. As you can see in the source text/html part is empty. I suppose we could try to workaround such situations and use text/plain. You should be able to see this message when you disable html.

comment:3 Changed 2 years ago by alec

  • Resolution set to fixed
  • Status changed from new to closed

comment:4 Changed 2 years ago by zamri

Ok I got it. I've tested it by editing rcube_message.php with your fix:

skip empty parts

if (!$sub_part->size)

continue;

Although the formatting is text-only but at least this workaround works.

Thx alec.

Last edited 2 years ago by zamri (previous) (diff)

comment:5 Changed 23 months ago by zamri

  • Resolution fixed deleted
  • Status changed from closed to reopened

I got a complaint from a user that she got an empty message after I applied the fix. here I attached the source beginning with the content-type:

Content-Type: multipart/mixed; boundary="=_mixed 0004233748257AA0_="

--=_mixed 0004233748257AA0_=
Content-Type: multipart/alternative; boundary="=_alternative 0004233848257AA0_="

--=_alternative 0004233848257AA0_=
Content-Type: text/plain; charset="US-ASCII"

--=_alternative 0004233848257AA0_=
Content-Type: text/html; charset="US-ASCII"

--=_alternative 0004233848257AA0_=--
01140912032287KOLEJ SHAHPUTRA ( GASC SDN BHD) 140920122301231713=20
0214091203911026065644 911026065644 NURRUL HIDAYAH BINT=
I 060600522185220000000675100 012
0214091203920202016222 920202016222 SITI NUR AISYAH BTE=
060500944095200000000850100 012
031409120300000200000000152520000000200000000152520000000000000000000000001=
2110148153242=20
=
--=_mixed 0004233748257AA0_=--
Dear Shafarina,

Please find attached report as per requested.

Kindly open the *.rpt file with Wordpad to view in proper format.

Moving forward, kindly email us at cimbib.cmimp@… for Direct Debit
related matters to avoid delay in response.

Thank you.

Regards,
Loo Ting Sin
Transaction Banking Malaysia - Implementation & Client Services
Corporate Banking, Treasury & Markets
Tel: +603 2084 6798 | Fax: +603 2096 1950
www.cimb.com

Connect with us on Facebook: www.facebook.com/CIMBMalaysia or follow us on
Twitter: www.twitter.com/CIMB_Assists

From:
Nana Ishak <shafarina@…>
To:
Loo Ting Sin <tingsin.loo@…>
Date:
18-10-2012 11:28 AM
Subject:
Re: Direct Debit Report - Shahputra 14/9/12

Last edited 23 months ago by zamri (previous) (diff)

comment:6 Changed 23 months ago by alec

Please, attach complete message source because this doesn't look valid.

Changed 23 months ago by zamri

comment:7 Changed 23 months ago by zamri

Forget above incomplete source. See attachment. I have opened it in Thunderbird and it contains no text message but 1 gif image as an attachment. In RC, I dont see any attachment.

Last edited 23 months ago by zamri (previous) (diff)

comment:8 Changed 23 months ago by alec

  • Resolution set to fixed
  • Status changed from reopened to closed

Ok. This is another case. The message is obviously malformed and we can assume that HTML part body is empty. Then we have an inline image related to HTML part. So, it is questionable if we should display it on the attachments list. For now, we decided to not display it, but you can open another ticket for this specific request. This is not a bug but designed behaviour.

comment:9 Changed 23 months ago by zamri

I added feature request for that: http://trac.roundcube.net/ticket/1488783. Thx

comment:10 Changed 23 months ago by thomasb

  • Milestone changed from 0.9-beta to 0.8.3

Adjust milestone.

Note: See TracTickets for help on using tickets.