Opened 2 years ago

Closed 2 years ago

#1488380 closed Bugs (fixed)

Missing Children in Inbox

Reported by: fraggy Owned by:
Priority: 5 Milestone: 0.8-rc
Component: IMAP connection Version: 0.8-beta
Severity: normal Keywords:
Cc:

Description

Hi,

I would like to use the newest nightly build, but something has changed in the way the inbox is listed.
Build r5675 works fine, but in all later versions I can't see my children inbox folders.

After login, all folders are listed in the left menu and I can click and see the whole content. Now when I go to "Settings" > "Folders" only the inbox root is shown. After switching back to "Mail" all folders disappear, except inbox.

These are the differences in the imap log:
r5675: [D91C] C: A0005 LIST "" "*"

r5957: [B285] C: A0007 LIST "" INBOX

Do I have to change something in the main config?

best regards
Maik

Attachments (2)

imap_r5675 (32.7 KB) - added by fraggy 2 years ago.
imap_r5957 (23.9 KB) - added by fraggy 2 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 2 years ago by fraggy

  • Version changed from 0.7.1 to 0.8-beta

comment:2 Changed 2 years ago by alec

  • Milestone changed from later to 0.8-rc

Show your imap_ns_* settings. Is caching enabled? Show imap_debug log starting from the moment when you log in to Roundcube.

Changed 2 years ago by fraggy

Changed 2 years ago by fraggy

comment:3 follow-up: Changed 2 years ago by fraggy

Hi,

i've tried to upload both imap logs, but your server is busy...

$rcmail_configimap_ns_personal? = "INBOX.";
$rcmail_configimap_ns_other? = null;
$rcmail_configimap_ns_shared? = null;

with
$rcmail_configimap_ns_personal? = null;
I got the same results, we are using dovecot.

Which caching u mean? Browser or Server side?

comment:4 in reply to: ↑ 3 Changed 2 years ago by alec

Replying to fraggy:

i've tried to upload both imap logs, but your server is busy...

$rcmail_configimap_ns_personal? = "INBOX.";

This is wrong. Your server supports NAMESPACE, just set all imap_ns_* to null.

with
$rcmail_configimap_ns_personal? = null;
I got the same results, we are using dovecot.

Which caching u mean? Browser or Server side?

I mean Roundcube cache. Works for me and I don't see in the code where it could ask for INBOX when listing folders. Try to disable all plugins and reinstall from scratch.

comment:5 Changed 2 years ago by alec

I've found in the code, that listing INBOX can happen when imap_ns_* is misconfigured. However, this doesn't explain why there's no LIST "" "*" request.

comment:6 Changed 2 years ago by fraggy

OK, I did a clean installation with nightly [54d07461] and the plugin folder from 0.8-beta and it works.
After enabling some plugins, I got the error again :(

I've disabled the 'subscriptions_option' plugin and all is fine. Maybe there is some bug?

comment:7 Changed 2 years ago by alec

  • Resolution set to fixed
  • Status changed from new to closed

Indeed, the bug was in subscriptions_option plugin. Fixed in r5963/svn.

Note: See TracTickets for help on using tickets.