Opened 3 years ago

Closed 3 years ago

#1488047 closed Bugs (worksforme)

exec_hook for request token fails in rcmail.php

Reported by: danielrauer Owned by:
Priority: 3 Milestone: 0.6-stable
Component: Core functionality Version: 0.6-beta
Severity: major Keywords: exec_hook request token
Cc:

Description

I have just updated our roundcube version 0.5.4 to 0.6-beta. This was done by using the new installto.sh script, which was running fine but reported an error at the end:
"PHP Fatal error: Call to a member function exec_hook() on a non-object in .../program/include/rcmail.php on line 1221"
This error is also reported each time the roundcube login page is accessed, no response is sent to the browser. The database seems to be updated properly ('words' column has been added in contacts table), also the config files look fine ('double_auth' config got removed, nothing else was mentioned).
Replacing the get_request_token method with the code from 0.5.4, that calls the md5-function directly, gets roundcube back to work: The login screen appears, all functions are working fine.
Did I miss anything in the update procedure?

Change History (1)

comment:1 Changed 3 years ago by alec

  • Resolution set to worksforme
  • Status changed from new to closed

Confirmed on forum, that re-install fixed the issue.

Note: See TracTickets for help on using tickets.