Opened 4 years ago

Closed 4 years ago

#1486579 closed Bugs (worksforme)

sent folder's email does not sort on Date correctly

Reported by: heitzso Owned by:
Priority: 5 Milestone: 0.4-beta
Component: Core functionality Version: 0.3.1
Severity: normal Keywords:
Cc: owen@…

Description

Click on "sent folder". Then click on date. The emails are not correctly sorted on date. Regular inbox folder sorts correctly on date. Let me know if you want any more information in order to replicate the problem

Change History (8)

comment:1 Changed 4 years ago by alec

  • Milestone changed from later to 0.4-beta
  • Resolution set to worksforme
  • Status changed from new to closed

Works for me. What imap server? Is index_sort enabled? Try using svn-trunk version.

comment:2 Changed 4 years ago by heitzso

  • Resolution worksforme deleted
  • Status changed from closed to reopened

IMAP server is Courier 4.3.1 (Ubuntu server, postfix/courier).

in config directory: grep sort *
main.inc.php: 'sort' => 'cn', The field to sort the listing by.
main.inc.php:$rcmail_configmessage_sort_col? = 'date';
main.inc.php:$rcmail_configmessage_sort_order? = 'DESC';
main.inc.php:$rcmail_configindex_sort? = TRUE;

I'll pull down svn and try. (... pause ...)
Both 0.3.1 and SVN are broken in this context (courier, settings).
When in SENT and click on DATE the order of the emails presented is random WRT date/time.

comment:3 Changed 4 years ago by alec

In svn you've got extended message list menu. Use it. Create a screenshot, also enable imap_debug and attach log here.

comment:4 Changed 4 years ago by omehegan

I am seeing this problem as well, or something like it. It affects all folders, and the issue seems to be that Roundcube is sorting based on the datestamp that the message was moved to the folder, rather than the datestamp of the message itself. If I have an email that I received a week ago, and I delete it/move it to Trash, and then view trash with messages sorted by date, newest first, that week-old message will be at the top of the list even though the displayed date is a week old. I'm using Courier IMAP 4.1.2 and Roundcube 0.3.1.

comment:5 Changed 4 years ago by omehegan

  • Cc owen@… added

comment:6 follow-up: Changed 4 years ago by alec

  • Resolution set to worksforme
  • Status changed from reopened to closed

No feedback.

comment:7 in reply to: ↑ 6 Changed 4 years ago by phs

  • Resolution worksforme deleted
  • Status changed from closed to reopened

I have the same problem that omehegan described.

How to reproduce:

  1. Create a new folder in RoundCube or take an existing one
  2. Take 2 or more E-Mails with different dates
  3. Drag and drop the newer one to your folder
  4. Drag and drop the older one to your folder
  5. When sorting on date, the older one is now the first and the newer one is the second mail.

comment:8 Changed 4 years ago by alec

  • Resolution set to worksforme
  • Status changed from reopened to closed

Did anyone of you tried svn-trunk version? Index_sort issue has been fixed (exactly has been changed, because this is not an issue).

Note: See TracTickets for help on using tickets.