Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#1485832 closed Bugs (fixed)

PHP Errors utf8.class.php and lib utf8.class UTF-7 to UTF-8

Reported by: lacri Owned by:
Priority: 5 Milestone: 0.3-stable
Component: Core functionality Version: git-master
Severity: normal Keywords: utf8, utf7
Cc:

Description

I recieved this error on errors log file

PHP Error: Failed to open map file for ISO-8859 in /var/www/htdocs/roundcube/program/lib/utf8.class.php on line 0

and
this error

PHP Error: Could not convert string from UTF-7 to UTF-8. Make sure iconv is installed or lib/utf8.class is available in /var/www/htdocs/roundcube/program/include/main.inc on line 0

iconv is installed

Attachments (2)

UTF7-Text.msg (7.1 KB) - added by lacri 5 years ago.
UTF7-HTML.msg (22.5 KB) - added by lacri 5 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 follow-up: Changed 5 years ago by alec

The first error is normal, 'ISO-8859' isn't a proper charset name. The second is probably because of wrong characters in the message (not matching UTF-7 encoding). For utf7 to utf8 conversion are used functions from lib/utf7.inc (if mbstring isn't installed). Iconv is not used for utf-7. Attach sample message.

comment:2 Changed 5 years ago by alec

  • Keywords utf8, utf7 added; utf8 removed

comment:3 in reply to: ↑ 1 ; follow-up: Changed 5 years ago by lacri

Replying to alec:

For utf7 to utf8 conversion are used functions from lib/utf7.inc (if mbstring isn't installed). Iconv is not used for utf-7. Attach sample message.

Sorry i have no sample message :( i will test this to reproduce this error.
mbstring is installed and enabled

Changed 5 years ago by lacri

Changed 5 years ago by lacri

comment:4 in reply to: ↑ 3 Changed 5 years ago by lacri

Replying to lacri:

Replying to alec:

For utf7 to utf8 conversion are used functions from lib/utf7.inc (if mbstring isn't installed). Iconv is not used for utf-7. Attach sample message.

Sorry i have no sample message :( i will test this to reproduce this error.
mbstring is installed and enabled

I have reproduce this
Step 1 compose a new HTML or Text message with microsoft outlook in UTF-7 with all Chars, Numbers and Sings from Keyboard and send to an RoundCube E-Mail Account
Step 2 open RoundCube and open the new incoming UTF-7 message the Message Display are very corrupt.
Step 3 Open RC error Log the Error Message is

PHP Error: Could not convert string from UTF-7 to UTF-8. Make sure iconv is installed or lib/utf8.class is available in /var/www/htdocs/roundcube/program/include/main.inc on line 0 (GET /roundcube/?_task=mail&_action=preview&_uid=150&_mbox=INBOX&_framed=1)

see attached Files

comment:5 Changed 5 years ago by alec

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in [a5897a3e].

comment:6 Changed 5 years ago by lacri

thx alec now works fine.

Note: See TracTickets for help on using tickets.