Opened 7 years ago

Closed 7 years ago

Last modified 5 years ago

#1484643 closed Bugs (invalid)

IMAP Authentication Error, but credentials and settings are confirmed to be correct

Reported by: svedman Owned by:
Priority: 5 Milestone:
Component: IMAP connection Version: 0.1-rc2
Severity: normal Keywords:
Cc:

Description

RoundCube works for all my IMAP accounts and servers, except one: imap.registrar.no. I cannot understand why, because this IMAP server works fine with other applications (Opera, SquirrelMail?, etc).

The error message in the log when I try to log in doesn't really say much either:

IMAP Error: Authentication for user@mydomain.tld failed (LOGIN): "a001 NO LOGIN failed" in  on line 0

Does this suggest that RoundCube is not sending the credentials correctly to some IMAP servers? The IMAP server is on a remote host, and tells me the following with Telnet:

$ telnet imap.registrar.no 143
Trying 213.179.58.79...
Connected to smtp.netclient.no.
Escape character is '^]'.
* OK [CAPABILITY IMAP4REV1 LOGIN-REFERRALS STARTTLS] JIMAP at 19-10-2007 09:31:23 +0000 (GMT)
a login user@mydomain.tld mypassword
a OK [CAPABILITY IMAP4REV1 IDLE MAILBOX-REFERRALS BINARY STARTTLS UNSELECT SCAN SORT THREAD=REFERENCES THREAD=ORDEREDSUBJECT MULTIAPPEND] User user@mydomain.tld authenticated
a logout
* BYE JIMAP server terminating connection
a OK LOGOUT completed
Connection closed by foreign host.

Again, RoundCube works for my other IMAP accounts on other servers.

I have checked the port number in main.inc.php, and it is correct. All settings are correct.

A copy of phpinfo() for the server RoundCube is running on is attached.

I had this problem in 0.1-rc1 and it still exists in 0.1-rc2.

Attachments (1)

phpinfo.html (47.4 KB) - added by svedman 7 years ago.
PHPInfo()

Download all attachments as: .zip

Change History (4)

Changed 7 years ago by svedman

PHPInfo()

comment:1 Changed 7 years ago by thomasb

  • Resolution set to invalid
  • Status changed from new to closed

This is not a support platform but a tracker for bugs. Get help in our forum or by posting to the users mailing list. If it turns out to be a real RoundCube bug please report with more details and steps to reproduce.

comment:2 Changed 7 years ago by svedman

  • Resolution invalid deleted
  • Status changed from closed to reopened

I have given you all the details I have, and I cannot give you any other steps to reproduce than to try to log in to the server in question with RC. Unfortunately, I do not own this server and cannot give you a test account, but I will keep testing this with newer RC versions.

I reported this as a bug because RC is the only application I have tried that doesn't work with this IMAP server (and I have tried several), and I think a developer should look at this.

I did post to the forum before reporting this, but were not able to solve the problem there with the help I got. That is because all my settings are correct, which again led me to think that this is a bug in RC.

Frankly, I think you should look at my report as a bug and investigate it, rather than seeing it as a support request, which it most definitely is not. This is why I am reopening this.

I am more than happy to assist you with what you need. If you STILL feel that this is not an issue that at least needs investigation and attention, please do re-invalidate it, and I will respect that.

comment:3 Changed 7 years ago by thomasb

  • Resolution set to invalid
  • Status changed from reopened to closed

How should we investigate without a test account? What needs to be done is to watch the network communication between RoundCube and your IMAP server. I cannot find much information about JIMAP which seems to be a java implementation of the IMAP protocol. Please understand that fixing this bug is simply impossible for us without more detailed information.

Note: See TracTickets for help on using tickets.