Opened 7 years ago

Closed 6 years ago

Last modified 4 years ago

#1484615 closed Bugs (duplicate)

Large msg attachments cannot be sent - and no error

Reported by: orvils Owned by:
Priority: 5 Milestone: later
Component: PHP backend Version: 0.1-rc1
Severity: normal Keywords:
Cc:

Description

E-mail with an attachment bigger than 2.1MB is not sending. When I upload the file and push "Send" button the "Sending e-mail" message appears, but after a while it disappears and no other error or message is displayed even when Debug=4.. No errors in logs as well.

On My other server I have this problem with an attachment of 1.1MB already. The difference between servers is that on the one where I have this error at 1.1MB files i have larger PHP vars:
upload_max_filesize = 100M and post_max_size = 110M

What Information could help you?

Change History (6)

comment:1 Changed 7 years ago by mastermind

I only wish to say that I have the same problem, and have considered creating a ticket for it myself. I experience a somewhat higher limit than 2.1 MB, though. In my testing, I have found that when the total e-mail size exceeds cirka 4 MB, the problem occurs. No errors, just like orvils has described.

I'm running Roundcube on Apache2 with PHP5 on a Debian GNU/Linux box. PHP's upload_max_filesize and post_max_size has been set to 64 MB. There was a limit set in the default .htaccess file in Roundcube as well (2 MB) - I have of course removed that.

In other webmails running on the same server (e.g. SquirrelMail?) this is not a problem, so there shouldn't be anything wrong with my PHP configuration.

I hope that you will find time to look into this. Thanks a lot for making a terrific webmail app! Keep up the good work!

Best regards,
mastermind

comment:2 Changed 6 years ago by mastermind

I'm becoming very unsure of the real limit here, this time I was able to send an e-mail on about 6 MB without problems, but when reaching about 8 MB the previously mentioned error occurs.

Anyhow, I want to confirm that this is still a problem in 0.1-rc2, and I thought I should mention something about what happens at the SMTP server. Here are some lines from my Postfix log, when the error occured in Roundcube:

Nov 17 18:30:32 dove postfix/smtpd[6824]: connect from panther[10.0.0.15]
Nov 17 18:30:32 dove postfix/smtpd[6824]: E3C90EC7BD: client=panther[10.0.0.15]
Nov 17 18:30:33 dove postfix/smtpd[6824]: lost connection after RCPT from panther[10.0.0.15]
Nov 17 18:30:33 dove postfix/smtpd[6824]: disconnect from panther[10.0.0.15]

"Panther" being the web server hosting Roundcube (Debian Etch with Apache 2 and PHP 5).

comment:3 Changed 6 years ago by seansan

  • Milestone set to 0.1.1
  • Summary changed from Emails with bigger attachments (2.1MB+) are not sending when (attachment uploads ok) to Large msg attachments cannot be sent - and no error

Review in 0.1.1 - not sure we can do anythin about it

comment:4 Changed 6 years ago by maho

I think that it's related to memory limit.

I have:

max_execution_time = 1000 ; to allow upload big attachment on slow connection
max_input_time = 1000 ; as above

and

memory_limit = 120M ; to allow parse big attachments

But when I attached 2 attachments: one 8mb, another 10mb and clicked "send":

  1. I got error in logs/errors:

PHP Fatal error: Allowed memory size of 125829120 bytes exhausted (tried to allocate 25497455 bytes) in /srv/www/poczta-rc.pagema.net/program/lib/Mail/mimePart.php on line 226

I think it's insane that 120MB isn't enough to send 18mb message.

  1. compose window is blocked. Buttons don't work and can't do anything but refresh browser.

comment:5 Changed 6 years ago by till

Can you verify those settings are in effect for the directory RoundCube is in?

<?php phpinfo(); ?>

Also, please check with recent version - 0.1.1 and SVN.

comment:6 Changed 6 years ago by alec

  • Component changed from Core functionality to PHP backend
  • Milestone changed from 0.2-beta to later
  • Resolution set to duplicate
  • Status changed from new to closed

No feedback and dupe of #1484660

Note: See TracTickets for help on using tickets.