Opened 7 years ago

Closed 7 years ago

#1484329 closed Bugs (duplicate)

adding contact from within email damages unicode on non-western characters

Reported by: admindomeny Owned by:
Priority: 3 Milestone:
Component: Client Scripts Version: 0.1-beta2
Severity: normal Keywords:
Cc:

Description

Let's say I got email from someone with Unicode char in name (not email address obviously).

The last name is "Dylag", where "a" here is unicode character:

http://www.fileformat.info/info/unicode/char/0105/index.htm

Now, adding manually contact with such name to address book works fine. However, when I got the mail from that guy, opened email and clicked plus character near the address to add him to contacts, the character is always added incorrectly: instead of one unicode character two random characters are added.

The source of webpage with opened email is as follows:

<td class="from" width="90%"><a href="mailto:wojciech.dylag@…" onclick="return rcmail.command('compose','wojciech.dylag@…',this)" class="rcmContactAddress" title="wojciech.dylag@…">Wojciech Dyląg [Domeny.pl sp. z o.o.]</a>&nbsp;<a href="#add" onclick="return rcmail.command('add-contact','Wojciech+Dyl%C4%85g+%5BDomeny.pl+sp.+z++o.o.%5D+%3Cwojciech.dylag%40domeny.pl%3E',this)" title="Dodaj do książki adresowej "><img src="skins/default/images/icons/plus.gif" alt="add" border="0" /></a></td>

It looks to me like the two characters in "Dylg" are two url-encoded characters that are probably incorrect.

Change History (1)

comment:1 Changed 7 years ago by thomasb

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #1484119

Note: See TracTickets for help on using tickets.