Opened 7 years ago

Closed 7 years ago

#1484320 closed Bugs (fixed)

Spell Check Not Working

Reported by: chengkingxiang Owned by: thomasb
Priority: 10 - Lowest Milestone:
Component: Website Version: 0.1-beta
Severity: normal Keywords:
Cc:

Description

I've managed to install Roundcube Webmail in my web hosting. While testing my spellcheck, it prompts an error saying:
"An error was encounter on the server. Please try again later."
What could possibly cause this problem?

Regards
Cheng King Xiang

Change History (5)

comment:1 Changed 7 years ago by crichardson

  • Resolution set to invalid
  • Status changed from new to closed

I dont believe this is a bug. please check the FAQ to see if it fixes you problem.
http://trac.roundcube.net/trac.cgi/wiki/FAQ

comment:2 Changed 7 years ago by chengkingxiang

  • Resolution invalid deleted
  • Status changed from closed to reopened

I'm still not able to use my spellcheck. It still prompts me error saying: "An error was encounter on the server. Please try again later."

Inside the folder config for the file main.inc.php, I've checked that the spellcheck is set to:
$rcmail_configenable_spellcheck? = TRUE;

And I've checked that the OpenSSL and Socket modules for PHP are enabled.

I've gone through all the FAQ with regards to my spellcheck problem but none of it can solve my problem.

May I know what could be the possible reason that I cannot use the spellcheck?

Regards
Cheng King Xiang

comment:3 Changed 7 years ago by crichardson

are you composing in plain text or are you using tinymce or whatever? also does anything show in the logs

comment:4 Changed 7 years ago by chengkingxiang

I'm using Micromedia Dreamweaver to compose my php file.

There are two files inside the log folder:
1) error
2) sendmail

Under the 'error' log file, here is one of the error message that is similar to the rest of the error messages:
[31-Mar-2007 16:39:03 -0500] DB Error: DB Error: connect failed in /hsphere/local/home/chengki0/tasteparadise.com.sg/webmail/program/include/rcube_db.inc on line 105

Under the 'sendmail' log file, here are the following error messages:
[31-Mar-2007 17:28:53 -0500] User: 1 on 85.90.206.117; Message for dmitry.pavlov@…; Subject: test

[31-Mar-2007 23:51:49 -0500] User: 2 on 218.186.8.10; Message for CHENG KING XIANG <king77@…>; Subject: Re: Testing

[31-Mar-2007 23:54:49 -0500] User: 2 on 218.186.8.10; Message for king77@…; Subject: Fwd: Testing

I don't see the above log errors have any linkage for not able me to use the spellcheck.

comment:5 Changed 7 years ago by chengkingxiang

  • Resolution set to fixed
  • Status changed from reopened to closed

Finally I have resolved my spellcheck problem!!
There are missing files in the latest version (0.1beta2.2) of RoundCube that makes the spellcheck not working.
Please download the missing files here:

http://www.howtoforge.com/forums/attachment.php?s=c7406fe250cbfb5c7171d87b2cd5a8a0&attachmentid=390&d=1173306053

Note: See TracTickets for help on using tickets.