Opened 7 years ago

Closed 4 years ago

#1484272 closed Feature Requests (worksforme)

Signature above original message on reply

Reported by: HYS Owned by: netbit
Priority: 5 Milestone: 0.4-beta
Component: User Interface Version: git-master
Severity: normal Keywords: signature
Cc: knut@…, leandro@…, ben@…, ck@…, roundcube.net@…, vbenincasa@…, osos@…, jhaagmans

Description

Now the signature is placed completely below the body of the message. I'd like to have my signature under my answer and above the original message.

Attachments (3)

top_posting_per_user.patch (5.2 KB) - added by epinter 5 years ago.
Top posting feature (per user). No database change required.
top_posting_per_user_r3078.patch (4.8 KB) - added by epinter 5 years ago.
Top posting feature (per user). For r3078.
app.js (91.3 KB) - added by rogernem 5 years ago.
MVISION skin version

Download all attachments as: .zip

Change History (42)

comment:1 Changed 7 years ago by crichardson

as far as I know most mail clients do not handle sigs this way.

comment:2 Changed 7 years ago by jpingle

Not to mention that top-posting is generally frowned upon in terms of netiquette (http://en.wikipedia.org/wiki/Posting_styles). But to each their own...

I have seen some mailers that insert the signature at the bottom of a reply, even if it's at the top of the message. Generally, these automatically paste the signature in the message before you start typing, and do not tack it on after you hit 'send'. Usually it's larger corporate-types who like to do this. Why, I don't know. Top-posting screws up the natural flow of discussion.

I propose two additional user preferences:

  1. An option, as in Thunderbird, to place your cursor at the top or bottom of a reply.
  2. An option to either insert the signature before you start composing or on send.

If a person chooses to both top-post and insert the signature before sending, what this particular person wants to do could be accomplished. If the signature is not inserted at the start, there is no way for RC to know where the quoted text really begins, and thus no way to know where to automatically place the signature.

comment:3 Changed 7 years ago by till

I don't really want to support that.

The "-- " in a signature, makes any good email client remove what's underneath of it. So when you put your signature before the quoted text. You lose it later on in discussion. For me that makes no sense to support.

A signature is supposed to be underneath of it.

comment:4 Changed 7 years ago by till

  • Milestone set to later

comment:5 Changed 6 years ago by alec

-1 from me

comment:6 Changed 6 years ago by minusonebit

I too would like to see this implemented (I submitted #1484737 which is apparently a duplicate of this one). I already made my arguments there which I wont rehash here.

There seems to be alot of folks very much against the inclusion of any such options. Too bad Round Cube doesn't support something like plugins or addons as they do in FireFox? or Thunderbird. Then this issue would be a moot point.

So, one vote in favor of this from me. Again.

comment:7 Changed 6 years ago by smultron

I vote for this too; I'd like to see this option. Perhaps it could be implemented with a warning:

Place reply and signature below quoted text (recommended)
or
Place reply and signature above quoted text (not-recommended)

At least then there'd be an option for those non-netiquette users, but still shows it's not 'proper'.

comment:8 follow-ups: Changed 6 years ago by PeterK2003

do people actually put there reply at the bottom? I have never seen this and honestly think it is a little weird...i want to see the most recent message first and then if i need more info i'll scroll down to see it.

Just my opinion but i would like to see this option implemented.

comment:9 Changed 6 years ago by ldeviator

some people really are die hard "bottom posters".. I'm not one of them

but, for me, I top post the reply but have my signature at the bottom... here at my company everyone does that also so I was happy to see Roundcube agrees :)

but, I hacked in to RoundCube a little and added some room at the top of messages to facilitate this.

I think if something like this would be implemented, one should check out Composition and Addressing in Thunderbird. For quoting a message they have:

[checkbox] Automatically quote the original message when replying Then:
start my reply above the quote
OR
start my reply below the quote
OR
select the quote

and place my signature
blow the quote (recommended)
OR
below my reply (above the quote)

comment:10 Changed 6 years ago by ldeviator

link to changes in javascript for top signatures (signatures after new post, above original reply)

comment:11 in reply to: ↑ 8 Changed 6 years ago by minusonebit

People that don't know the difference between Usenet and e-mail do. This whole mindset of e-mail being a "conversation" is what led to the creation of g-mail, the world's worst e-mail service. heh, and if you notice, g-mail even puts the most recent message at the top of the thread - or it tries to, I should say. Usually it starts a new thread like an annoying board troll. E-mail is not a "conversation". Think of it like sending electronic postcards back and forth. You may save all your postcards, but do you read all the previous ones before the one that came in the mail today? Maybe if you have a few screws loose, but most people would read the most recent postcard, then refer to the older ones as, when and if needed.

Having to scroll through previous quoted messages (which can sometimes be pages and pages in length) to get the signature of a message is just goofy, but I realize some people just have to be different, so whatever, I find it very annoying. The idea that I should scroll past all that crap to find the message as well is just plain goofy. Unless that e-mail was from a boss or someone important (i.e. someone who has something I want - i.e. a paying customer), I'd likely delete it rather than read it. Time is too precious to waste it on people who waste it intentionally by being petty.

Replying to PeterK2003:

do people actually put there reply at the bottom? I have never seen this and honestly think it is a little weird...i want to see the most recent message first and then if i need more info i'll scroll down to see it.

Just my opinion but i would like to see this option implemented.

comment:12 in reply to: ↑ 8 Changed 6 years ago by jpingle

Replying to PeterK2003:

do people actually put there reply at the bottom? I have never seen this and honestly think it is a little weird...i want to see the most recent message first and then if i need more info i'll scroll down to see it.

Just my opinion but i would like to see this option implemented.

As I like to say...

A: Because it breaks the flow of a message

Q: Do you know why I hate top-posting?

comment:13 Changed 5 years ago by adurelli

  • Component changed from Client Scripts to User Interface
  • Milestone changed from later to 0.3-stable

I think a better solutio would be adding a "signatre button". Let`s say I want to send a joke to a friend. No need to put my signature on it. Now let´s say I want to send a report to a co-worker. I simply click on a button and my signature is inserted on the current cursor position. This way you ca put (or not) your sganture anywhere.

comment:14 Changed 5 years ago by alec

Ticket #1485738 marked as duplicate of that issue.

comment:15 Changed 5 years ago by Luzifer

  • Cc knut@… added

Vote for this too.

I would really like to see this option implemented at the earliest date. The signature belongs to the reply and not to the quoted text and therefore it should be added directly after the reply (which is in my case at the TOP of the whole conversation - Never saw anyone I have to work with adding the reply below the quote). (Just my 2 cents)

comment:16 Changed 5 years ago by leandropetreca

  • Cc leandro@… added

Vote for this!

In Brazil, everybody put the reply on the top! I think its common in some countries. A checkbox in the settings would resolve this problem

comment:17 Changed 5 years ago by mrngoitall

I'd also like to see this put into the next milestone; not everyone agrees with the philosophy of top-posting vs. bottom-posting; trying to enforce it on all Roundcube users only results in people searching for patches to make it accommodate their needs and makes the experience of installing Roundcube much more cumbersome. I agree with the idea of adding a checkbox to resolve this issue.

comment:18 Changed 5 years ago by bjuteau

  • Cc ben@… added

comment:19 Changed 5 years ago by Napsty

  • Cc ck@… added

comment:20 Changed 5 years ago by fuscata

  • Cc roundcube.net@… added

I vote for this too.

Some of my users top post, some bottom post. If RC forces either, I will be forced to find a new email client.

comment:21 Changed 5 years ago by netbit

  • Cc vbenincasa@… added
  • Owner set to netbit
  • Status changed from new to assigned
  • Version changed from 0.1-rc1 to svn-trunk

comment:22 Changed 5 years ago by alec

Implementing this we should also add an option to not remove sender signature on reply.

comment:24 Changed 5 years ago by epinter

  • Milestone changed from 0.3.1 to later
  • Type changed from Feature Requests to Patches

I made this patch to add an option in identity configuration. The user can enable/disable top-posting for each identity (the default is disabled, the normal behavior of rcmail). There are 2 files, the patch and txt with SQL query to add the field required (in identities table).

http://www.4shared.com/file/141048256/4607ba2c/roundcube_topposting_patch.html

This patch successfully apply with 2602 and 3043 trunk revisions.

comment:25 Changed 5 years ago by epinter

  • Type changed from Patches to Feature Requests

comment:26 follow-up: Changed 5 years ago by epinter

  • Milestone changed from later to 0.3.1

comment:27 in reply to: ↑ 26 Changed 5 years ago by cityhunter

good and work in trunk-3056

Changed 5 years ago by epinter

Top posting feature (per user). No database change required.

comment:28 Changed 5 years ago by epinter

Another patch, this don't need any database change, it's a per-user configuration.

comment:29 Changed 5 years ago by epinter

Forgot to mention, the patch was made for [024130be] ... Maybe needs some minor adjust to newer versions...

Changed 5 years ago by epinter

Top posting feature (per user). For r3078.

comment:30 Changed 5 years ago by alec

  • Resolution set to fixed
  • Status changed from assigned to closed

Implemented in [50f56d20].

Changed 5 years ago by rogernem

MVISION skin version

comment:31 Changed 5 years ago by rogernem

  • Resolution fixed deleted
  • Status changed from closed to reopened

Can you please help me with my app.js version?
(http://trac.roundcube.net/attachment/ticket/1484272/top_posting_per_user_r3078.patch)
Thanks

See attached file:
app.js (91.3 KB) - added by rogernem 14 seconds ago.
MVISION skin version

comment:32 Changed 5 years ago by alec

  • Resolution set to fixed
  • Status changed from reopened to closed

This is not a support forum. Ask for help on mailing list.

comment:33 follow-up: Changed 5 years ago by rogernem

It seems at least. What are all these messages and comments above them?
What´s the link so someone can help me?

You should try this patch in this version. Does not work.
That´s why I posted the other file here.

comment:34 in reply to: ↑ 33 Changed 5 years ago by till

Replying to rogernem:

It seems at least. What are all these messages and comments above them?
What´s the link so someone can help me?

You should try this patch in this version. Does not work.
That´s why I posted the other file here.

Hey Roger,

unless your problem is related to this bug, please don't comment on this ticket.

Instead I propose you either open a new issue which details your problem or you email the dev@ mailing list for assistance and describe how we may be able to help.

Generally, this issue has been fixed in trunk. If you have issues with a custom template, I think you may either need to update your template or contact the template author so they update.

HTH,
Till

comment:35 Changed 5 years ago by osos

  • Cc osos@… added

comment:36 Changed 4 years ago by philipt75

An option for placing sig above text is needed. Every email client has that option. Roundcube has a nice clean design, I like it over horde or squirrelmail, but falls short on this, I think it looks bad on an email with out a signature, you hit reply to a new email and you write your piece and there is no name, company, address etc, client has to scroll down to find, madness. Especially with ebay replies, all those ebay emails have TONS of text and to scroll through all that crap to get to our signature, crazy.

comment:37 Changed 4 years ago by jhaagmans

  • Cc jhaagmans added
  • Resolution fixed deleted
  • Status changed from closed to reopened

I'm happy to see the option has been added to Roundcube. However, Firefox still puts the signature at the bottom. The only difference is that it puts it right under the quote, instead of leaving two blank lines like when top posting is disabled. This has been tested on Windows (3.6.3) and on Linux (latest version). In IE it works fine, but I don't use IE.

Does anyone else see this behaviour and can it be changed? Top posting is something I've been waiting for for a very long time. Not having it was one of the downsides of using Roundcube.

comment:38 Changed 4 years ago by Napsty

Which version of Roundcube do you use? 0.4 Beta? There was a bug in it.
I use trunk-r3656/svn and there it was fixed.

comment:39 Changed 4 years ago by alec

  • Resolution set to worksforme
  • Status changed from reopened to closed

Also works for me. Use svn-trunk and check config options. Add more info if you'll need to reopen.

Note: See TracTickets for help on using tickets.