Opened 8 years ago

Closed 7 years ago

#1484023 closed Bugs (fixed)

message display on invalid charset header

Reported by: bettwanze Owned by:
Priority: 6 Milestone: 0.1-rc2
Component: PHP backend Version: 0.1-beta2
Severity: normal Keywords:
Cc:

Description

If the received message has a charset header which doesn't actually match the contents of the message body (e.g. charset=us-ascii whereas german umlauts are used) the message is only display up to the first appearance "invalid" char in the message body. Would be nice if RC could be a little more "error tolerant"...there are quite a few broken MUAs out there... ;-)

Attachments (3)

charset_problem.txt (1.1 KB) - added by bettwanze 8 years ago.
sample message with german umlauts
message.png (24.1 KB) - added by crick 7 years ago.
charsets problem in headers
message.txt (2.7 KB) - added by crick 7 years ago.

Download all attachments as: .zip

Change History (13)

comment:1 Changed 8 years ago by thomasb

Could you provide a sample message? I tested it (german umlauts and charset=us-ascii) with 8bit and quoted-printable encodings and the message was displayed correctly in both cases.

comment:2 Changed 8 years ago by bettwanze

Here's the message in question. Last sentence in message body is "Der Anrufer hat zwar die Ansage geh". The part after and including the "ö" is not displayed in the message window but visible if viewed as source.

Changed 8 years ago by bettwanze

sample message with german umlauts

comment:3 Changed 8 years ago by lancey

It displays as "?" on my setup, and the whole message body is visible. I don't see the issue...

Tested on Firefox 1.5 / IE6, SVN [4e6eb1fb]

comment:4 Changed 7 years ago by crick

I have the same problem with Russian charsets.

Sorry for my bad english.

Changed 7 years ago by crick

charsets problem in headers

Changed 7 years ago by crick

comment:5 Changed 7 years ago by crick

Sorry, but my problem is not the same. My problem that in heading of the letter the wrong charset though in a body of the letter all is correct.

comment:6 Changed 7 years ago by thomasb

  • Component changed from Client to PHP backend
  • Milestone set to 0.1-rc2
  • Severity changed from minor to normal

This might be an iconv Problem. We need to append either TRANSLIT or IGNORE to the iconv call. From the php manual: "Otherwise, str is cut from the first illegal character."

comment:7 Changed 7 years ago by thomasb

Ticket #1484452 marked as duplicate of this bug.

comment:8 Changed 7 years ago by thomasb

Here's a patch for this problem: #1484420

comment:9 Changed 7 years ago by thomasb

Ticket #1484034 marked as duplicate of this bug.

comment:10 Changed 7 years ago by thomasb

  • Resolution set to fixed
  • Status changed from new to closed

IGNORE added to trunk in [b8e65ce3]

Note: See TracTickets for help on using tickets.