Opened 8 years ago

Closed 7 years ago

#1456834 closed Bugs (fixed)

INBOX empty at login

Reported by: nobody Owned by: roundcube
Priority: 5 Milestone:
Component: Client Scripts Version: None
Severity: critical Keywords:
Cc:

Description

The INBOX is empty when I login. For one second I can
see that there are new mails cause they displayed in
the brackets at the INBOX Folder. After the second they
are away. The Inbox mail overview is empty all the
time. only if I open another folder and then go back to
Inbox I can see the new mails.

Change History (6)

comment:1 Changed 8 years ago by seando

Logged In: YES 
user_id=1484447

I can confirm this.  It takes an inbox refresh for all new
messages (or any messages sometimes) to show up in the
message list.

comment:2 Changed 8 years ago by nobody

Logged In: NO 

I would confirm this as well.  It is a bit more widespread,
however.  In constant use, I never see new emails unless I
click on another folder and then go back to the inbox.

Today I logged in at 10:40 AM.  I had no new email.  I
clicked on trash and then back to inbox.  I now had several
emails, all from before 10:40 AM.

This can be triggered with any folder, not just the trash.

comment:3 Changed 8 years ago by nobody

Logged In: NO 

It appears that disabling the message cache resolves this.
It is an unfortunate work-around though, since the cache is
there to presumably speed things up. In my experience it's
still plenty fast, and having messages load when you login
is certainly faster than clicking in and out of the inbox
everytime.

Here's the code you're looking for:
 
// enable caching of messages and mailbox data in the local
database.
// this is recommended if the IMAP server does not run on
the same machine

$rcmail_config['enable_caching'] = FALSE;

comment:4 Changed 8 years ago by roundcube

  • Status changed from assigned to closed
Logged In: YES 
user_id=1262041

Definitely a caching issue. Should be solved in current CVS
version

comment:5 Changed 8 years ago by anonymous

  • Resolution Fixed deleted
  • Severity set to critical
  • Status changed from closed to reopened

Still experiencing problems with latest SVN. With caching enabled new messages appear in the Inbox but show all the header properties of the previous message (Sender, subject, read status)

Disabling caching resolves the problem

comment:6 Changed 7 years ago by thomasb

  • Resolution set to fixed
  • Status changed from reopened to closed

Too old...

Note: See TracTickets for help on using tickets.